Create SVG map for Pricing Map

To make an SVG map, please find your original Powerpoint document, or if you've imported it into TM for safekeeping, you can export it to get the original file.

You must also have completed the steps to set up the graphic map under the Graphic Map tab for box office sales.

Making an SVG Map from the Powerpoint document

The best way we have found to create a very useable SVG map will closely match your existing box office maps is to use Open Office (free) and your original PPT document or Adobe Illustrator (paid).

Note: after you have created an SVG document that is to your liking, you can use OpenOffice to make your PPT map edits from that point forward if you feel comfortable using it as an editing tool as well as a graphics format conversion tool.

Exporting the Original PPT Map

After making your final changes to the graphic map, you should save it to the database so that you can retrieve it later on - should you want to alter and aspect of the map or use it to make another pricing map for dynamic pricing..

Saving the original (Powerpoint) copy of the Map into the Database

Saving the original file that was used to create the maps:

  • Select the Description tab on the Pricing Map editing window.
  • Click on your powerpoint document
  • Drag it on top of the button that will be labelled 'Import PPT File' or 'Update PPT File' as indicated below
  • Release the mouse
  • If the message at the bottom of the screen indicates 'Source PPT document imported', you are done.

Exporting the Original PPT Map from the Database

If you have saved the original source drawing/map in the database as recommended, you can export it out again. Traditionally, we have used Powerpoint to create maps, but it has always been possible to use other drawing tools like LibreOffice or a WMF drawing tool.

  • Click on the Description Tab
  • Click on the Export toolbar icon at the top of the screen
  • Select Map - Source Document Format (.ppt)
  • Select the location to save the file- the desktop is a good place for working with it. It will default to a name that matches your pricing map name.

Exporting the WMF (or PICT) and convert to PPT to SVG

If the powerpoint document is not available, the basic steps for converting a WMF (or PICT) to an SVG from an old map are as follows:
  • Start Theatre Manager using the 32 bit version. You cannot use the 64 bit version to get the SVG
  • Find the Price Map for which you seem to only have a WMF or Pict format image
  • From the toolbar of the Price Map window, click Export button, then select the file format to export WMF (or PICT on a mac) to a file and save on the desktop.

    Export File

  • Start Powerpoint
    • Select the Insert menu item and
    • pick the the exported WMF or pict image from the file dialog
  • Ctrl-A to select everything on the map
    • Ungroup everything.
      • An alert may appear stating the file is an imported image and
      • asks Do you want to convert the file to a MS Office drawing object.
      • Click YES

        Import File to PowerPoint

    • Ungroup again - and repeat until you can't ungroup any more items
    • Remove some of the white background artifacts and and unwanted junk from the conversion process
  • Select all the remaining objects again (use Ctrl-A):
    • move them where you want them to be and
    • resize the overall image using page setup as necessary (but don't adjust object size). This is done by:
      • Select all items (Ctrl-A)
      • Use Cut (usually Ctrl-X) to get take them off the page. make sure they are all gone, or else use undo)
      • Change the Page Size to be smaller in either Height or Width
      • Paste (Ctrl-V) the objects. if they fall out side the page size, repeat the above and change the page size, until you find that all the objects fit nicely on the page
      • Doing this determines the final display size of the image at the box office and on the web - you don't want extraneous white space

  • Save the document in PPT format (not PPTX)
  • Now you have a PPT that you can use in the the Convert to SVG process

Prepare the PPT Document the First Time

If this is the first time you are converting the pricing map PPT document to SVG to prepare it for pick-your-own seats, there are a few steps that will help in the process. Once you are happy with the map and it converts nicely to SVG, you should not have to do this step again.
  • Open the document in Powerpoint (any version should work - these steps were tested with office 2008 for mac)
  • UNGROUP all objects:
    • Select ALL of the objects on the drawing and UNGROUP them.
    • Repeat the above steps until you can no longer ungroup any items on the picture
  • Fix any row or seat # text that used spaces to separate text and turn each row or seat # into individual objects. To do this:
    • Look for the names of rows and/or seat numbers (as per the diagram)
    • Make sure seat or row number is its own object. If not, re-do them so that they are and put things in the same position
    • Each item must also be either vertical or horizontal. They cannot be rotated.
    • Remove any large empty objects that contribute nothing to the map. Some maps seem to have a large white background object that is extraneous.
    • We recommend that if you have a lot of white space at one end of your map or at the bottom that you crop the white space to make it look better online. You can do this by:
      • Saving a copy of the PPT document before starting
      • Select ALL objects on the Map
      • If there is a lot of white space at the top or left of the document, dragging all objects the map up and to left to provide what you think is an acceptable margin
      • Note the approximate amount of space you may wish to remove from right and bottom to make the map have a balanced margin
      • Cut ALL the objects from the Map so that the map is empty.
      • Go to Page Setup
      • Write down the width and height measurements
      • Subtract the amount of whitespace from the width and height. For example, if the document looks to have 2 inches of white space on the right, then make the width 2 inches smaller
      • PASTE the objects back in to the document.
      • If there is too much (or not enough) white space, then CUT all items, change the page size dimensions and PASTE again.
      • Repeat until you like the look of the picture

    If you make changes to the location of the background objects while tidying things up or altering the page size, please remember to update the box office sales map:

    • Save the PPT file
    • Export the picture to drop into the graphic map tab as you would normally do
    • Select all the seats and move them seats to correspond with the background
    • Save the graphic map
    • Copy the PPT file back into the database

    Convert PPT to SVG (using OpenOffice)

    There are tools that can convert a PPT to SVG format file:
    • Open Office (free), also derived from Sun Microsystems and diverged from Libre Office a while back. Use Version 4.1.4 or later from their web site.
    • Some venues have used Adobe Illustrator CS6 effectively.

    This page describes using then for its picture conversion capabilities (eg PPT to WMF, PPT to PICT, or PPT to SVG).

    1. Open the PPT document in Libre Office or Open Office. You can do this by using the File->Open menu after starting LibreOffice or you can drag your PPT document onto the empty window
    2. Select File->Export option as per the picture below:

    3. When the File dialog opens, click the file type option and pick the export file type. There are a number of options but the ones that are of interest are:
      • SVG - Scaleable Vector Graphics - which is the one we will pick to get the SVG file
      • PCT - Mac Pict Format - can be used to export the PPT document to PCT format for the OSX graphic map for the box office
      • WMF - Window Metafile - can be used to export the PPT to WMF format for the Windows graphic map for venues using windows machines